aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorCan2024-12-11 21:46:50 +0100
committerGitHub2024-12-11 21:46:50 +0100
commit0740a71446abe5227ee44b56301806de3c31046d (patch)
tree0d46a4a8d27731f0b6fb6c5921ea01156bbe17b2 /flake.nix
Initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix62
1 files changed, 62 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..fe7c09f
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,62 @@
+{
+ ## TODO: Change to your project's description:
+ description = "Nix template for Effekt projects";
+
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ effekt-nix = {
+ url = "github:jiribenes/effekt-nix";
+ inputs.nixpkgs.follows = "nixpkgs";
+ inputs.flake-utils.follows ="flake-utils";
+ };
+ };
+
+ outputs = { self, nixpkgs, flake-utils, effekt-nix }:
+ ## If you want only some specific systems, do the following instead:
+ # flake-utils.lib.eachSystem ["aarch64-linux" "aarch64-darwin"] (system:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = import nixpkgs { inherit system; };
+ effekt-lib = effekt-nix.lib.${system};
+
+ ## Project configuration
+ # TODO: Change to your project's details:
+ pname = "effekt-template"; # package name
+ version = "0.1.0"; # package version
+ mainFile = "src/main.effekt"; # relative path to entrypoint (as a string)
+ testFiles = [ "src/test.effekt" ]; # relative paths to tests (as a string)
+
+ ## Effekt configuration
+ effektConfig = {
+ ## Uncomment and set a specific version if needed:
+ # version = "0.10.0";
+
+ ## Select the backends that your project works on:
+ backends = with effekt-lib.effektBackends; [ js ];
+ };
+
+ # Chooses the correct Effekt package.
+ effektBuild = effekt-lib.getEffekt effektConfig;
+ in {
+ packages.default = effekt-lib.buildEffektPackage {
+ inherit pname version;
+ src = ./.;
+ main = mainFile;
+ tests = testFiles;
+
+ effekt = effektBuild;
+ inherit (effektConfig) backends;
+ };
+
+ devShells.default = effekt-lib.mkDevShell {
+ effekt = effektBuild;
+ };
+
+ apps.default = flake-utils.lib.mkApp {
+ drv = self.packages.${system}.default;
+ name = pname;
+ };
+ }
+ );
+}