aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin Borner2020-04-25 15:31:09 +0200
committerMarvin Borner2020-04-25 15:31:09 +0200
commit30601e14f216488ee3a36dc44ab0ed56da7ccdb2 (patch)
tree3bef128513ce569b64788853d688179ac7562096 /CMakeLists.txt
parent24175ce2a37d6f5d9ba367f942fabce681ee9e4a (diff)
Working ext2 filereader
As soon as I implement indirect block pointers, the resources will hopefully work again :)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3612ddb..035dd77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,7 +46,7 @@ add_executable(resources ${resources_sources})
set_target_properties(resources PROPERTIES OUTPUT_NAME "${CMAKE_CURRENT_SOURCE_DIR}/build/font.o")
add_custom_command(
TARGET resources POST_BUILD
- COMMAND cross/opt/bin/i686-elf-objcopy -O binary build/font.o iso/font.bin
+ COMMAND cross/opt/bin/i686-elf-objcopy -O binary build/font.o build/font.bin
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
)
@@ -56,7 +56,7 @@ target_include_directories(user PUBLIC "src/userspace/")
set_target_properties(user PROPERTIES OUTPUT_NAME "${CMAKE_CURRENT_SOURCE_DIR}/build/user.o")
add_custom_command(
TARGET user POST_BUILD
- COMMAND cross/opt/bin/i686-elf-objcopy -O binary build/user.o iso/user.bin
+ COMMAND cross/opt/bin/i686-elf-objcopy -O binary build/user.o build/user.bin
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
)