aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin Borner2020-04-25 18:33:37 +0200
committerMarvin Borner2020-04-25 18:33:37 +0200
commit71a111f7e6b71e0894b90e8dc1221b1ec4f84ab3 (patch)
tree78a8340f7909429d91f560ba2915959a4d313a1b /CMakeLists.txt
parent30601e14f216488ee3a36dc44ab0ed56da7ccdb2 (diff)
Added indirect pointers - re-enabled font :)
I don't know why, but once there are multiple files on the drive the kernel can only read one file.. I'll investigate this later.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 035dd77..4cf3ba4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,7 @@ target_link_libraries(kernel PRIVATE "-T ${CMAKE_CURRENT_SOURCE_DIR}/src/kernel/
# RESOURCES
add_executable(resources ${resources_sources})
set_target_properties(resources PROPERTIES OUTPUT_NAME "${CMAKE_CURRENT_SOURCE_DIR}/build/font.o")
+target_compile_options(resources PRIVATE "-Os")
add_custom_command(
TARGET resources POST_BUILD
COMMAND cross/opt/bin/i686-elf-objcopy -O binary build/font.o build/font.bin