aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPherkel2023-09-04 22:55:27 +0200
committerGitHub2023-09-04 22:55:27 +0200
commit93e49e708fa59613406249069d31c2f6c8f2d2ab (patch)
tree9f413c226283db990116c9559ffffb9124b911d8 /pyproject.toml
parent14ceeb5ad36beea2f05214aa26260cdd1d86590b (diff)
parent0d70a19e1fea6eda3f7b16ad0084591613f2de72 (diff)
Merge pull request #27 from Algo-Boys/refactor_modularize
Refactor modularize
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fabe364..57c60c9 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -11,7 +11,6 @@ packages = [{include = "swr2_asr"}]
python = "^3.10"
torch = "2.0.0"
torchaudio = "2.0.1"
-audioloader = {git = "https://github.com/marvinborner/AudioLoader.git"}
tqdm = "^4.66.1"
numpy = "^1.25.2"
mido = "^1.3.0"
@@ -25,6 +24,15 @@ pylint = "^2.17.5"
ruff = "^0.0.285"
types-tqdm = "^4.66.0.1"
+[tool.ruff]
+select = ["E", "F", "B", "I"]
+fixable = ["ALL"]
+line-length = 120
+target-version = "py310"
+
+[tool.black]
+line-length = 100
+
[tool.poetry.scripts]
train = "swr2_asr.train:run_cli"
train-bpe-tokenizer = "swr2_asr.tokenizer:train_bpe_tokenizer"