aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPherkel2023-08-17 18:53:35 +0200
committerPherkel2023-08-17 18:53:35 +0200
commitcc401846811207b8aa2da881f52e8d37f06ef6cd (patch)
tree43ffb0ee52d8914a7307e0e8e54768feb85d5d48 /pyproject.toml
parentc9136fbba5ac5bd394a9c164173b64e22a1b2950 (diff)
Added poetry, improve project structure
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..aadfdbb
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,43 @@
+[tool.poetry]
+name = "swr2_asr"
+version = "0.1.0"
+description = "Automatic speech recognition with pytorch for SWR2"
+authors = ["Philipp Merkel <philippmerkel@outlook.com>", "Marvin Borner <git@marvinborner.de>", "Valentin Schmidt <>", "Silja Kasper <>"]
+license = "MIT"
+readme = "README.md"
+packages = [{include = "swr2_asr"}]
+
+[tool.poetry.dependencies]
+python = "^3.10"
+numpy = "^1.25.2"
+click = "^8.1.6"
+
+[tool.poetry.group.cpu]
+optional = true
+
+[tool.poetry.group.cpu.dependencies]
+torch = "=2.0.1"
+torchaudio = "=2.0.2"
+
+[tool.poetry.group.dev.dependencies]
+black = "^23.7.0"
+pylint = "^2.17.5"
+mypy = "^1.5.1"
+pre-commit = "^3.3.3"
+
+[[tool.poetry.source]]
+name = "pytorch"
+url = "https://download.pytorch.org/whl/cu111/"
+priority = "supplemental"
+
+[[tool.poetry.source]]
+name = "PyPI"
+priority = "primary"
+
+[[tool.mypy.overrides]]
+module = "torchaudio.*"
+ignore_missing_imports = true
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"