aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPherkel2023-09-18 18:13:46 +0200
committerGitHub2023-09-18 18:13:46 +0200
commitf94506764bde3e4d41dc593e9d11aa7330c00e30 (patch)
tree6fc438536a72e195805c1aea97926f4c9bbd4f85 /pyproject.toml
parent8b3a0b47813733ef67befa6959a4d24f8518b5b7 (diff)
parent21a3b1d7cc8544fa0031b8934283382bdfd1d8f1 (diff)
Merge pull request #38 from Algo-Boys/decoder
Decoder
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f6d19dd..6f8915f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -18,12 +18,14 @@ tokenizers = "^0.13.3"
click = "^8.1.7"
matplotlib = "^3.7.2"
pyyaml = "^6.0.1"
+pandas = "^2.1.0"
[tool.poetry.group.dev.dependencies]
black = "^23.7.0"
mypy = "^1.5.1"
pylint = "^2.17.5"
ruff = "^0.0.285"
+ipykernel = "^6.25.2"
[tool.ruff]
select = ["E", "F", "B", "I"]
@@ -35,9 +37,8 @@ target-version = "py310"
line-length = 100
[tool.poetry.scripts]
-train = "swr2_asr.train:run_cli"
-train-bpe-tokenizer = "swr2_asr.tokenizer:train_bpe_tokenizer"
-train-char-tokenizer = "swr2_asr.tokenizer:train_char_tokenizer"
+train = "swr2_asr.train:main"
+recognize = "swr2_asr.inference:main"
[build-system]
requires = ["poetry-core"]