aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b7e6ffb..eb17479 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,7 +8,7 @@ readme = "readme.md"
packages = [{include = "swr2_asr"}]
[tool.poetry.dependencies]
-python = "~3.10"
+python = "^3.10"
torch = "2.0.0"
torchaudio = "2.0.1"
audioloader = {git = "https://github.com/marvinborner/AudioLoader.git"}
@@ -16,6 +16,7 @@ tqdm = "^4.66.1"
numpy = "^1.25.2"
mido = "^1.3.0"
tokenizers = "^0.13.3"
+click = "^8.1.7"
[tool.poetry.group.dev.dependencies]
black = "^23.7.0"