aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml34
1 files changed, 11 insertions, 23 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 606633b..8490aa5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,40 +1,28 @@
[tool.poetry]
-name = "swr2_asr"
+name = "swr2-asr"
version = "0.1.0"
-description = "Automatic speech recognition with pytorch for SWR2"
-authors = ["Philipp Merkel <philippmerkel@outlook.com>", "Marvin Borner <git@marvinborner.de>", "Valentin Schmidt <>", "Silja Kasper <>"]
+description = ""
+authors = ["Philipp Merkel <philippmerkel@outlook.com>"]
license = "MIT"
readme = "readme.md"
packages = [{include = "swr2_asr"}]
[tool.poetry.dependencies]
-python = "^3.10"
-numpy = "^1.25.2"
-click = "^8.1.6"
-audioloader = {git = "https://github.com/KinWaiCheuk/AudioLoader.git"}
+python = "~3.10"
+torch = "2.0.0"
+torchaudio = "2.0.1"
+audioloader = {git = "https://github.com/marvinborner/AudioLoader.git"}
tqdm = "^4.66.1"
-torch = {version = "^2.0.1+cpu", source = "pytorch-cpu"}
-torchaudio = {version = "^2.0.2+cpu", source = "pytorch-cpu"}
+numpy = "^1.25.2"
+mido = "^1.3.0"
[tool.poetry.group.dev.dependencies]
black = "^23.7.0"
-pylint = "^2.17.5"
mypy = "^1.5.1"
-pre-commit = "^3.3.3"
-
-[[tool.poetry.source]]
-name = "pytorch-cpu"
-url = "https://download.pytorch.org/whl/cpu"
-priority = "explicit"
-
-
-[[tool.poetry.source]]
-name = "pytorch-gpu"
-url = "https://download.pytorch.org/whl/cu118"
-priority = "explicit"
+pylint = "^2.17.5"
[tool.poetry.scripts]
-train = "swr2_asr.train:main"
+train = "swr2_asr.train:run_cli"
[build-system]
requires = ["poetry-core"]