aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin Borner2020-04-29 00:39:24 +0200
committerMarvin Borner2020-04-29 00:39:24 +0200
commit50858d043cbd6f61cc091c6772f981ca2d6cca6b (patch)
tree82afcc2daf9c4b67d29832923283654913490d06 /CMakeLists.txt
parent34c752f6fe4f71169172f1b3e46b1eddf69eba6e (diff)
Added basic exec calls for init and started libc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a650621..d77fb54 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,6 +58,7 @@ target_include_directories(userspace_lib PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/src
foreach(loop_file ${user_sources})
get_filename_component(testname ${loop_file} NAME_WE)
add_executable(${testname} ${loop_file})
+ target_compile_options(${testname} PRIVATE "-nostdinc")
target_include_directories(${testname} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/src/userspace/libc/")
target_link_libraries(${testname} userspace_lib "-T ${CMAKE_CURRENT_SOURCE_DIR}/src/userspace/linker.ld")
set_target_properties(${testname} PROPERTIES OUTPUT_NAME "${CMAKE_CURRENT_SOURCE_DIR}/build/user/${testname}")