summaryrefslogtreecommitdiff
path: root/rpm/harbour-sailchess.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rpm/harbour-sailchess.spec')
-rw-r--r--rpm/harbour-sailchess.spec67
1 files changed, 67 insertions, 0 deletions
diff --git a/rpm/harbour-sailchess.spec b/rpm/harbour-sailchess.spec
new file mode 100644
index 0000000..86a2217
--- /dev/null
+++ b/rpm/harbour-sailchess.spec
@@ -0,0 +1,67 @@
+#
+# Do NOT Edit the Auto-generated Part!
+# Generated by: spectacle version 0.27
+#
+
+Name: harbour-sailchess
+
+# >> macros
+# << macros
+
+Summary: Awesome chess application
+Version: 0.1
+Release: 1
+Group: Qt/Qt
+License: LICENSE
+URL: http://example.org/
+Source0: %{name}-%{version}.tar.bz2
+Source100: harbour-sailchess.yaml
+Requires: sailfishsilica-qt5 >= 0.10.9
+BuildRequires: pkgconfig(sailfishapp) >= 1.0.2
+BuildRequires: pkgconfig(Qt5Core)
+BuildRequires: pkgconfig(Qt5Qml)
+BuildRequires: pkgconfig(Qt5Quick)
+BuildRequires: desktop-file-utils
+
+%description
+Short description of my Sailfish OS Application
+
+
+%prep
+%setup -q -n %{name}-%{version}
+
+# >> setup
+# << setup
+
+%build
+# >> build pre
+# << build pre
+
+%qmake5
+
+make %{?_smp_mflags}
+
+# >> build post
+# << build post
+
+%install
+rm -rf %{buildroot}
+# >> install pre
+# << install pre
+%qmake5_install
+
+# >> install post
+# << install post
+
+desktop-file-install --delete-original \
+ --dir %{buildroot}%{_datadir}/applications \
+ %{buildroot}%{_datadir}/applications/*.desktop
+
+%files
+%defattr(-,root,root,-)
+%{_bindir}
+%{_datadir}/%{name}
+%{_datadir}/applications/%{name}.desktop
+%{_datadir}/icons/hicolor/*/apps/%{name}.png
+# >> files
+# << files